Kamrad.ru
 
 
дневники | кабинет | регистрация | календарь | участники | faq | правила | поиск | фотоальбом | каська | выйти
Kamrad.ru Kamrad.ru » Форумы общей тематики » Программы (software) » Проблема с настройкой сети
новая тема  ответить следующая тема | предыдущая тема
Автор
 
gedmax - offline gedmax
19-08-2004 16:12 URL сообщения      K-Mail    Профиль    Поиск    Контакт-лист   Редактировать
Камрад



Проблема с настройкой сети

Сколько сетей настраивал - первый раз такая проблема: комп с Win98, входит в группу WORKGROUP с еще 4 компьютерами. Адреса стандартно заданы 192.168.0.x, маска подсети - 255.255.255.0. Скорость для тестирования у всех поставлена 10 MB. Соединяются по TCP/IP, хотя для чего стоят IPX, NetBIOS для IPX, NetBEUI (не мои настройки, но на всех компах все одинаковые). Все компьютеры видят друг друга в сети, все сетевые диски, принтеры, но этот - хоть и видит все файлы, может узнать размер и свойства файлов на другом компьютере, но при копировании создает файл нулевого размера, сообщает "Сетевое устройство более не доступно" и удаляет этот файл. Копировал и с 98, и с ХР машин - то же самое. В чем трабл - все-таки в настройках или в железе?

ЗЫ Забыл написать, что с этого компьютера файлы легко копируются на любой и после этого легко удаляются, а на него - нет.

Igorvs - offline Igorvs
19-08-2004 18:38 URL сообщения      K-Mail    Профиль    Поиск    Контакт-лист   Редактировать
Модератор



тааак...
Попробуем разобраться...
1) Какие остальные компы ( с какой ОС)
2) есть ли сервера в сети ? ( Novell например )
3) Зачем в сети NETBIOS

Делаем следующее:
Везде оставляем только TCP/IP протокол
Адреса 192.168.0.х
Маска подсети 255.255.255.0 ( хотя можно и меньше сделать)
Остальные протоколы убиваем.
проверяем настройки сети на каждом компьютере командой ipconfig/ all
Провереяем работу протокола по принципу:
1) Ping 127.0.0.1
2) ping localhost
3) ping адресов всех остальных машин ( 3-х)
4) ping default gateway ( если есть выход наружу)
5) ping IP в интернете ( если есть выход наружу)
6) ping адрес в интернете ( например www.ya.ru) ( если есть выход наружу)

Если все вышеперечисленное настроено и работает - все -ок.
Если нет - надо искать ответы в физике сети...

gedmax - offline gedmax
19-08-2004 20:54 URL сообщения      K-Mail    Профиль    Поиск    Контакт-лист   Редактировать
Камрад



1) 4 машины на 98 и одна на 2000 Pro
2) Сервера нет (если не считать 2000, которая используется как файл-сервер)
3) Не могу сказать, почему такие настройки, не я ставил, но при удалении - машина перестает видется в сетевом окружении, скорее всего из-за того что NetBios к IPX привязан, то есть думаю нужно у всех машин сразу сносить.
Действительно, попробою завтра оставить один TCP/IP (сейчас доступа для проверки нет), но самое интересное, что и пинги все проходять меньше чем 1 мс, и все машины спокойно общаются, а одна только в одну сторону зараза работает.

Интернета там нет, так что только локальные адреса проверю.
А для чего 127.0.0.1 пинговать?

Igorvs - offline Igorvs
20-08-2004 12:58 URL сообщения      K-Mail    Профиль    Поиск    Контакт-лист   Редактировать
Модератор



Наличие NETBIOS как протокола никоим образом не влияет на видимость сетевого окружения. Распространенная ошибка начинающих сетевиков.
Для того чтобы видилось окружение вполне достаточно работы TCP/IP протокола и локальной службы браузинга.

127.0.0.1 - это Localhost
Его необходимо пинговать для проверки работоспостобности протокола на конкретной машине

Могу посоветовать следующее:
удалить настройки ВСЕХ протоколов на машине и с нуля настроит один tcp/ip чтобы быть уверенным что все верно.
Сеть работает в одну сторону - скорее всего физика - либо перебита жила кабеля , неправильный обжим ну или глюки сетевой карты ( драйвера, замена в тестовых целях на другую).

Wiz - offline Wiz
20-08-2004 13:31 URL сообщения      K-Mail    Профиль    Поиск    Контакт-лист   Редактировать
Модератор



Было нечто похожее: файлы либо копировались очень долго, либо не копировались. Все остальное было ОК.
Оказалось - битая сетевуха.

gedmax - offline gedmax
20-08-2004 16:38 URL сообщения      K-Mail    Профиль    Поиск    Контакт-лист   Редактировать
Камрад



Сегодня попробовал снести остальные протоколы, да и вообще сетевую карту удалил, заново поставил драйвера, настроил только TCP/IP на всех машинах - та же история все машины видят друг друга, пинги и локальные и по сети проходят, все сетевые ресурсы видны, но при копировании с этой машины каких-нибудь файлов к себе из сети копируются только пустые папки и пишет опять сволочь "Сетевое устройство более не доступно". У остальных компов такой проблемы нет. Пробовал пробросить кабель-времянку, сам обжал - то же самое, то есть не в кабеле дело. Сетевую карту пока не получиться заменить (в остальных встроенные в материнские, а здесь Realtek стоит). Для чистоты эксперимента еще можно операционку переставить, а то она также как и настройки неизвестного происхождения. Ну и в конце концов придется сетевую найти похоже. Буду пробовать, о результатах напишу.

Еще вопрос по NetBios'у. Если я ставил у одной машины NetBios с привязкой к IPX, а у другой просто IPX (еще на старых настройках сети, когда был IPX), даже пинги не проходили, не то что в окружении виделись. Потому и подумал, что NetBios влияет на общение. Это не так?

Спасибо.

gedmax - offline gedmax
23-08-2004 15:29 URL сообщения      K-Mail    Профиль    Поиск    Контакт-лист   Редактировать
Камрад



Уфф, все-таки настроил - в сетевухе дело оказалось, точнее она то рабочая. Просто в драйверах некорректно выбиралась скорость сети, а сеть не тянула на полной скорости. Переобжим кабеля не помог, потому что кабель неизвестного происхождения и только на 10 позволяет работать. Заменил сетевую, где можно нормально скорость установить и все заработало, правда опять же только на 10. Ну и пусть мучаются.

Igorvs - offline Igorvs
23-08-2004 17:25 URL сообщения      K-Mail    Профиль    Поиск    Контакт-лист   Редактировать
Модератор



gedmax
Знакомая ситуация - карта рабочая - кабель. г...
Лечилось принудительным выставлением на сетевухе - 10 мб half duplex. Но посылы были к этому - нестабильный пинг на 100 мегабит и отвал машины при попытке логона ( не найден контроллер домена)

Текущее время: 18:21
новая тема  ответить следующая тема | предыдущая тема
 
Перейти:

версия для печати   отправить эту страницу по e-mail   подписаться на эту тему

 
Powered by: vBulletin Version 2.0.1
Copyright ©2000, 2001, Jelsoft Enterprises Limited.
Любое использование материалов сайта
возможно только с разрешения его администрации.


 

Рейтинг@Mail.ru
Рейтинг@Mail.ru